Exchange 2010-Deinstallationsfehler

1 Beitrag in diesem Thema

Update 15:35h: jetzt auch mit Dingen, die ich schon ausprobiert habe...

 

Mahlzeit,

ich habe gerade ein Problem mit einer Exchange 2010-Deinstallation, wo ich nicht weiter komme, evtl. hatte das schon mal jemand und kennt die Lösung. :)

Gegeben ist folgendes:

- Windows SBS 2011 mit Exchange 2010 SP1 mit Update Rollup 7 (es wurde schon versucht, SP2 oder SP3 zu installieren, was kläglich gescheitert ist)

- Windows Server 2012 R2 mit Exchange 2010 SP3 mit Update Rollup 12, wo alle Postfächer, öffentlichen Ordner etc. hin migriert wurden, so dass der Exchange auf dem SBS "leer" ist

Es soll ein Exchange 2016 installiert werden, das geht jedoch nur, wenn der Exchange 2010 SP1 aus dem Netzwerk raus ist, deswegen will ich den dementsprechend deinstallieren. Die Postfachdatenbanken auf dem Exchange des SBS sind entfernt (nicht nur "Bereitstellung aufgehoben", sondern komplett aus der Konfiguration entfernt), auch Sende- und Empfangsconnectoren gibt es nicht mehr. Nun habe ich die Deinstallation auf dem SBS angestoßen, die Postfach- und Clientzugriffsrollen wurden auch ordnungsgemäß deinstalliert, allerdings bricht das Setup bei der Deinstallation der Hub-Transportrolle ab.

 

Was ich schon ausprobiert habe:

- Powershell-Script uninstall-AntispamAgents.ps1 aus dem Exchange-Script-Verzeichnis ausgeführt

- Ordner Setup von der Exchange-Installations-DVD (ohne SP1) in das Exchange-Verzeichnis kopiert, da sich vorher die Postfach- und Clientszugriffsrollen nicht deinstallieren ließen

- Deinstallation über GUI (nur die Hub-Transportrolle abgewählt) und über Kommandozeile (setup.com /mode:uninstall /roles:H)

 

Leider gibt es per Websuche nach Unregister-ContentFilter nur Einträge, wie man den Content-Filter bei Webseiten deaktiviert oder wie man den Content-Filter im Exchange konfiguriert, aber nicht wie man den deregistriert.

 

Die (meiner Meinung nach) relevanten Einträge im ExchangeSetup.log sind die folgenden (11.02. heißt 2. November...):

[11.02.2016 14:11:15.0821] [1] Processing component 'Transport Common Configuration' (Konfigurieren allgemeiner Transporteinstellungen.).
[11.02.2016 14:11:15.0821] [1] Executing:
    unregister-ContentFilter
	
[11.02.2016 14:11:15.0821] [2] Die Active Directory-Sitzungseinstellungen für 'Unregister-ContentFilter' lauten: Vollständige Gesamtstruktur anzeigen: 'True', Konfigurationsdomänencontroller: 'SBS-MEDIASYSTEM.mediasystem.local', Bevorzugter globaler Katalog: 'SBS-MEDIASYSTEM.mediasystem.local', Bevorzugte Domänencontroller: '{ SBS-MEDIASYSTEM.mediasystem.local }'
[11.02.2016 14:11:15.0821] [2] Beginning processing unregister-ContentFilter
[11.02.2016 14:11:15.0821] [2] [ERROR] Failed to unregister the content filter.
[11.02.2016 14:11:15.0821] [2] [ERROR] Zugriff verweigert
[11.02.2016 14:11:15.0837] [1] The following 1 error(s) occurred during task execution:
[11.02.2016 14:11:15.0837] [1] 0.  ErrorRecord: Fehler beim Aufheben der Registrierung des Inhaltsfilters.
[11.02.2016 14:11:15.0837] [1] 0.  ErrorRecord: Microsoft.Exchange.Data.Common.LocalizedException: Fehler beim Aufheben der Registrierung des Inhaltsfilters. ---> System.ComponentModel.Win32Exception: Zugriff verweigert
   bei System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.ContentFilterRegistration.InternalProcessRecord()
   --- Ende der internen Ausnahmestapelüberwachung ---
[11.02.2016 14:11:15.0837] [1] [ERROR] The following error was generated when "$error.Clear();
    unregister-ContentFilter
	" was run: "Fehler beim Aufheben der Registrierung des Inhaltsfilters.".
[11.02.2016 14:11:15.0837] [1] [ERROR] Failed to unregister the content filter.
[11.02.2016 14:11:15.0837] [1] [ERROR] Zugriff verweigert
[11.02.2016 14:11:15.0837] [1] [ERROR-REFERENCE] Id=TransportCommonComponent___3e4d1208017a4e8fa529b1d72483ac82 Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup
[11.02.2016 14:11:15.0837] [1] Setup is stopping now because of one or more critical errors.
bearbeitet von Eye-Q

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!


Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.


Jetzt anmelden