Jump to content

fstab macht mir die Hölle heiß

Empfohlene Beiträge

Aloa,

ich habe 2 neue Workstations bestellt und gleichzeitig Suse 10.2 (ja ich stehe auf bedrucktes Material), da wir mit Suse 10.1 unzufrieden waren da es des öftern einfror.

Nun läuft es auch schon ein paar Tage tadelos doch dann fiel mir ein, ich muss ja noch die Netzlaufwerke einhängen. Also stinknormale Win-Netzlaufwerke.

Habe ich also erstmal testmount gemacht und dies funktionierte auch auf anhieb. Also habe ich dann fstab bearbeitet und folgendes hinzugefügt:

//rechnername/d /rechnername_d smbfs uid=1000,gid=100,credenti als=/etc/usercred,rw,auto 0 0

Jaaaaaaaa. Funktioniert nicht oO. Ich dachte mir, vllt. bin ich ja einfach nur zu blöd wer weiß. Also einfach mal in der fstab des anderen Linuxrechners nachgeschaut und nö, alles richtig geschrieben. Wusst ichs doch. Nach ca. 5 Stunden elendes quälen und hin und her überlegen habe ich dann mal google angestrengt und siehe da er wurde fündig. Leider unterstützt 10.2 diese vorgehensweise nichtmehr und dies ist auch kein Bug sondern gewollt. Toll.

Also cifs ausprobiert allerdings hab ich das nie genutzt und ein wirklich hilfreiches HoTo scheint auch mangelware zu sein.

Kann mir jemand helfen die Laufwerke cifs-mäßig zu mounten? Also beim Systemstart?

Danke im vorraus

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kann mir jemand helfen die Laufwerke cifs-mäßig zu mounten? Also beim Systemstart?

Name

mount.cifs — mount unter Verwendung des Common Internet File System (CIFS).

Synopsis

mount.cifs {service} {mount-Punkt} [-o Optionen]

Also ich würde mal sagen (hab noch nie cifs gemountet), du schreibst dir ein kleines shell-skript, dass dein cifs mountet (s.o.) und das rufst du beim Systemstart auf (rc3.d o.ä.).

So mache ich es mit Novell-Shares.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Also ich würde mal sagen (hab noch nie cifs gemountet), du schreibst dir ein kleines shell-skript, dass dein cifs mountet (s.o.) und das rufst du beim Systemstart auf (rc3.d o.ä.).

So mache ich es mit Novell-Shares.

Ja diese möglichkeit habe ich auch in betracht gezogen aber ich bin ein sehr ordnungsliebender Mensch daher wollt ichs lieber im fstab haben. ;)

Ich bin halt kein typischer Admin wo alles umherflattert. Nicht böse sein aber gerade die Novelladmins sind etwas chaotisch dabei aber sehr sympathisch.:)

Also bleibt mir scheinbar nur das Skript oder gibts noch andere Ideen?

PS: Nimms mir bitte nicht übel aber so ist meine Sichtweise. Hab bisher ja auch nur einen Novellianer kenngelernt und der ist wie ein verrückter Professor. Wahnsinnig, möhlig, größenwahnsinnig, durchgeknallt! Aber schwer in ordnung^^

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Nicht böse sein aber gerade die Novelladmins sind etwas chaotisch dabei aber sehr sympathisch.:)

Ich hab mit Novelladmins auch nur beruflich zu tun ;) Ich bin Anwendungsentwickler und das administrative Zeug mach ich nur, weil es sonst ja keiner tut und man es eh am besten selber macht ;) Und das aber auch nur wegen ein paar Lösungen von mir, die eben z.B. für die Sicherung eine Anbindung an den Netwareserver brauchen.

EDIT:

Und eine bessere Lösung haben auch unsere Novelladmins nicht gefunden, trotz Novell/Suse-Linux und SLES-Servern (die hier laufen) etc. (und Novellpartnerschaft)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

also ich mounte das bei mir auch ganz normal über die fstab. Hab ansich nur das smbfs durch nen cifs ersetzt. Dabei gab es eine kleine Schwierigkeit die ich leider nimmer weiss aber probier es einfach mal aus und poste die eventuelle Fehlermeldung.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
also ich mounte das bei mir auch ganz normal über die fstab. Hab ansich nur das smbfs durch nen cifs ersetzt. Dabei gab es eine kleine Schwierigkeit die ich leider nimmer weiss aber probier es einfach mal aus und poste die eventuelle Fehlermeldung.

Habe ich auch gemacht. Ich bekomme allerdings keine Fehlermeldung. Er bootet als wenn nichts wäre und wenn ich dann auf das Netzlaufwerk zugreifen möchte, dann ist der Ordner einfach leer^^.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Fehlermeldung gibt es dann sicher irgendwo weil der mount hat ja nicht geklappt. :).

Hast du mal versucht das von Hand zu mounten ?

Von Hand hat es funktioniert. Sogar mit SMB Mount.

Tja sag mir wo und ich rück die Fehlermeldung sofort rüber bzw. werte sie selber aus ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

würde auf /var/log/messages tippen aber so schlau warst du sicherlich selber schon.

Schau mal folgende Diskussion durch vielleicht ist da was für dich bei:

Thema anzeigen - mount über CIFS klappt nicht über die fstab (suse 10.2) - SuSE Linux

Ich bin nun erstmal im Feierabend bzw mich in die Gartenarbeit stürzen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Was passiert den, wenn du zusätzlich noch dmask=777 und fmask=777 in die fstab Zeile einfügst? (Vollzugriff ist bei mir durchaus gewünscht ;) ) .

Ohne diese Zeile wollte bei mir ein RH 7.2 eine Windowsfreigabe auch nicht beim Booten mounten.

Kann sein, dass man diese Option erst recht bei cifs braucht.

Wobei fmask und dmask bei cifs anscheinend anders heisst:

//server/share /path/to/mountpoint cifs iocharset=utf8,uid=localusername,gid=users,guest,file_mode=0777,dir_mode=0777 0 0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

also ich habe das auch noch nicht allzuoft benötigt (weil wir Windows-Rechner normal gerne mal vor der Tür stehen lassen :D ), aber meiner Meinung nach sollte das über die /etc/samba/smbfstab kein Problem sein!

Und so wirds konfiguriert (als root):


schlaubi:/etc/samba# cat /etc/samba/smbfstab

# This file allows you to mount SMB/ CIFS shares during system boot while

# hiding passwords to other people than root.  Use /etc/fstab for public

# available services.  You have to specify at least a service name and a mount

# point.  Current default vfstype is smbfs.

#

# Possible vfstypes are smbfs and cifs.

#

# The options are explained in the manual page of smbmount and mount.cifs.

#

# service       moint-point     vfstype options


;//fjall/test    /data/test      cifs    username=tridge,password=foobar

# Schlaubi, Apr-2007, CIFS-Testmount

//192.168.3.1/freigabe1                        /opt/data1/freigabe1 cifs rw,username=admin,password=xyz




schlaubi:/etc/samba# vi /etc/samba/smbfstab # Dateibackup, anpassen und abspeichern

schlaubi:/etc/samba# rcsmbfs start

schlaubi:/etc/samba# rcsmbfs status

Rein damit in die Runlevels 3 und 5 und dann ist das auch bootfest :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Aloa

@Schlaubi....so habe ich es auch schon ausprobiert. Auch im smbfstab allerdings hatte ich die Zeile ";//fjall/test" nicht mit drin. Was genau bedeutet diese Zeile?

@Carnie...Den Thread habe ich schon zuvor durchgegraben;) aber trotzdem danke. Heute habe ich nochmal was neues versucht und Schwupps da steht was im log drin. Ich werde es im laufe des Tages mal posten.

@KlausZettel...Das war eine gut Idee. Leider hats bei mir nicht geholfen^^.

Danke nochmal für eure Hilfsbereitschaft. Ich werde später erstmal die Logmeldung auswerten und wenn ich dann nicht weiter weiß Poste ich sie in diesem Thread nochmal und dann können wir ja mal weiterschauen.:)

PS Windoze ist doch das beste Betriebssystem aller Zeiten vor allem Vista:baby: Ich kann es nur jedem empfehlen (Nein ich bin kein Windoze hasser aber Vista ist böse:beagolisc )

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

OK hier mal ein paar Auszüge:

Apr 18 17:34:42 salamander sudo: user : TTY=pts/0 ; PWD=/home/user ;

USER=root ; COMMAND=/bin/mount -t cifs -o username=blub,password=blubberdiblub //jupiter/d /jupiter_d

dann weiter unten:

Apr 18 17:36:52 salamander kernel: CIFS VFS: Error connecting to IPv4 socket. Aborting operation

Apr 18 17:36:52 salamander kernel: CIFS VFS: cifs_mount failed w/return code = -101

Scheinbar kann er nicht auf das Internetprotokoll Version 4 zurückgreifen aber

warum nicht? oO

Ich schäme mich für die Frage aber man kann ja auch mal daneben liegen. Also:

Kann das was damit zu tun haben?:

Apr 18 17:50:31 salamander kernel: IPv6 over IPv4 tunneling driver

PS: Hab ich die Editfunktion nicht gefunden weils keine gibt oder weil ich Blind bin oder weil sie gut versteckt ist? :confused:

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
@Schlaubi....so habe ich es auch schon ausprobiert. Auch im smbfstab allerdings hatte ich die Zeile ";//fjall/test" nicht mit drin. Was genau bedeutet diese Zeile?

Das ist doch nur eine Beispielzeile und das ; am Anfang wird als Kommentarzeichen, ähnlich # interpretiert.

Apr 18 17:36:52 salamander kernel: CIFS VFS: cifs_mount failed w/return code = -101

Hast Du schonmal nach dem Error Code recherchiert?

Hast Du schonmal versucht, die Zeile so in die /etc/samba/smbfstab einzutragen?

//jupiter/d /jupiter_d cifs rw,username=blub,password=blubberdiblub

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Das ist doch nur eine Beispielzeile und das ; am Anfang wird als Kommentarzeichen, ähnlich # interpretiert.

Habe ich mir schon fast gedacht. Ich wollte nur auf nummer sicher gehen und nochmal nachharken.

Hast Du schonmal nach dem Error Code recherchiert?

Ja schon aber leider ohne Ergebnis. Ich habe auch alle benötigten Pakete kontrolliert ob eins fehlt aber dem ist auch nicht so.

Hast Du schonmal versucht, die Zeile so in die /etc/samba/smbfstab einzutragen?

//jupiter/d /jupiter_d cifs rw,username=blub,password=blubberdiblub

Jap. Alles gestern schon ausgiebig getestet ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nimm an der Diskussion teil

Du kannst jetzt hier posten und Dich später registrieren. Wenn Du bereits über eine Konto verfügst, melde Dich jetzt an, um mit Deinem Konto zu posten.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


Fachinformatiker.de, 2019 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung