Zum Inhalt springen

Div. Fragen zu (Cisco) Routern/Routing

Empfohlene Beiträge

Hi Leute,

folgendes:

Ich habe zwei Cisco Router (2811) via Cross Over Kabel miteinander verbunden (jeweils über das FastEthernet 0/0 Interface).

Den zwei Interfaces habe ich jeweils eine IP Adresse zugewiesen (RouterA: 192.168.1.2/24 und RouterB: 192.168.2.2/24).

Wenn ich nun von RouterA aus einen Ping auf die 192.168.2.2 (RouterB) schicke, erhalte ich keine Rückmeldung.

Woran kann das liegen?

Was mich auch noch interessieren würde:

Ich habe einen Cisco Router mit 4 FastEthernet Ports. Ich möchte nun an diesen Router 2 PCs anschließen, die sich im gleichen Netz befinden. Ich müsste nun also zwei Interfaces mit jeweils einer IP aus dem gleichen Netz konfigurieren, was allerdings nicht geht (nur 1 Interface pro Netz). Gibt es noch eine Lösung ohne Switch/Hub?

Was mich ebenfalls noch interessiert:

Ein Cisco Switch out of the box- "switcht" dieser schon oder muss dieser erst noch konfiguriert werden?

Hinweis:

Keine Angst, wir reden hier nicht von Produktivsystemen! ;-)

Bearbeitet von mosQ

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Den zwei Interfaces habe ich jeweils eine IP Adresse zugewiesen (RouterA: 192.168.1.2/24 und RouterB: 192.168.2.2/24).

Wie sollen die mit einander reden, wenn die nicht im selben Netz sind?

Was mich auch noch interessieren würde:

Ich habe einen Cisco Router mit 4 FastEthernet Ports. Ich möchte nun an diesen Router 2 PCs anschließen, die sich im gleichen Netz befinden. Ich müsste nun also zwei Interfaces mit jeweils einer IP aus dem gleichen Netz konfigurieren, was allerdings nicht geht (nur 1 Interface pro Netz). Gibt es noch eine Lösung ohne Switch/Hub?

Mit Vlan´s und dann Switch-Mode Access, weißt du wie dies geht, sonst sag bescheid.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Falls du nicht aufgepasst hast, Router sind dafür da, verschiedene Netze miteiander zu verbinden... also müssen die nicht im selben Netz sein.

Falls du nicht aufgepasst hast, er hat 2 Router mit nem Cross-Kabel verbunden und den Interface Adressen aus 2 Netzen gegeben!!!!!

Wie soll das funktionieren????:mod:

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Hi Leute,

folgendes:

Ich habe zwei Cisco Router (2811) via Cross Over Kabel miteinander verbunden (jeweils über das FastEthernet 0/0 Interface).

Den zwei Interfaces habe ich jeweils eine IP Adresse zugewiesen (RouterA: 192.168.1.2/24 und RouterB: 192.168.2.2/24).

Wenn ich nun von RouterA aus einen Ping auf die 192.168.2.2 (RouterB) schicke, erhalte ich keine Rückmeldung.

Woran kann das liegen?

Wie soll er denn auch eine Rückmeldung geben, wenn er noch nichtmals mitbekommt, dass er überhaupt angesprochen wird? ;)

192.168.1.2/24 und 192.168.2.2/24 liegen nicht im gleichen Netz und daher kann zwischen den IPs nur per Router kommuniziert werden. Dafür braucht man aber einen Router, der Interfaces in beiden Netzen hat, damit er die Pakete entweder ans eine Netz oder ans andere Netz weiterreicht. So funktioniert es jedenfalls nicht, da das Paket vom Router verworfen wird. er kennt das Netz ja nicht. Da seine Antwort auch nicht ankommt, kriegst du keine Rückmeldung von ihm.

Was mich auch noch interessieren würde:

Ich habe einen Cisco Router mit 4 FastEthernet Ports. Ich möchte nun an diesen Router 2 PCs anschließen, die sich im gleichen Netz befinden. Ich müsste nun also zwei Interfaces mit jeweils einer IP aus dem gleichen Netz konfigurieren, was allerdings nicht geht (nur 1 Interface pro Netz). Gibt es noch eine Lösung ohne Switch/Hub?

Dafür brauchen die Interfaces keine IP, da sie ja nicht zwischen den Netzen vermitteln müssen. Evtl ist das eh ein kleiner Switch nur, was du meinst.

Was mich ebenfalls noch interessiert:

Ein Cisco Switch out of the box- "switcht" dieser schon oder muss dieser erst noch konfiguriert werden?[...]

Zum reinen switchen muss nichts konfiguriert werden, ausser evtl die Ports hochschalten, falls sie auf shutdown stehen. Ich glaub per default sind sie aber nicht geshuttet.

[edit]

oooh upps - da kamen ja einige Posts noch zwischen seit ich das letzte mal geschaut hatte hier vorm abschicken

[/edit]

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Danke Leute.

Ich dachte ursprünglich wie Forcid, aber Freak One und Crash2001 haben natürlich recht- war ein Denkfehler von mir.

Nun hab ich's gecheckt und es funktioniert. Danke.

@Freak One:

Wenn du mir was bzgl. Vlan´s und dann Switch-Mode Access erzählen könntest, wäre ich dir dankbar, aber bitte nur, wenn dir das nicht zu viel Aufwand ist.

Gruß

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Beispielconfig auf ner Cisco 87X

!

interface vlan 1

ip address 192.168.1.1 255.255.255.0

no shut

!

interface fastethernet0

switchport access vlan 1

no shut

!

interface fastethernet1

switchport access vlan 1

no shut

!

fertig ;)

mit vlan 1 ist das natürlich witzlos, weil jeder switchport default in vlan 1 steckt. aber vom prinzip her macht man das so.

funzt übrigens auf diese art NICHT auf den "nativen" Interfaces (also den onboard interfaces) von 18xx,28xx und co. sondern dort nur auf den Ports des 4fach Fastethernet HWIC.

Um das auf den "nativen" Interfaces zu machen ist das minimal aufwendiger, allerdings krieg ich das grad auswendig nicht mehr runter getippt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Bei dem einen oder anderen IOS kann es sein, das das Vlan noch in die Database eingetragen werden muss.

VLAN 10 in die database eintragen (direkt, ohne vorher conf t zu tippen, im enable-modus)

!

vlan database

vlan 10 (oder 11 oder 15 oder 73 (Standart VLAN 1-1000))

exit

!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Sofern die Eitnragung in die VLAN Database nicht notwendig ist wird man aber auch durch entsprechende "deprecated" meldungen informiert.

C hat eine neue Syntax für das VLAN-Handling eingeführt. Die Konfig erfolgt jetzt direkt aus dem Konfig-Modus. Daher die deprecated-Meldung bei "vlan data". Aber das wird sicher keiner vermissen...

Mirko

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ist mir vollkommen klar und bewusst.

ABER es gibt noch genügend router und switches die noch eine genügend alte IOS version fahren, dass man das thema trotzdem erwähnen muss.

von daher hab ich mir angewöhnt erst das anlegen via vlan database zu checken und NUR bei exppliziter deprecated meldung eben die "neue" variante zu verweden.

letztlich schaded die deprecated variante ja auch bei neuen ios (noch) nicht. umgekehrt funzt es halt net, wenn mans vergessen hat :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Deine Meinung

Du kannst jetzt schreiben und Dich später registrieren. Wenn Du ein Konto hast, melde Dich an , um mit Deinem Konto zu schreiben.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Nur 75 Emojis sind erlaubt.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


Fachinformatiker.de, 2020 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung