Jump to content

Postfix-Problem beim Empfang von Mails

Empfohlene Beiträge

Hallo zusammen,

anbei meine / unsere Problemstellung.

Ich doktore hier schon seit knapp 2 Wochen an einem Postfixproblem rum.

Betriebssystem ist Debian, der Rest ist denk ich in diesem Fall mal unwichtig.

Folgendes Problem tritt auf: Beim senden von Mails von extern kommt die Mail blöderweise so zurück

<user@domain2.org>: host emailgateway.domain.de[XXX.XX.XXX.XXX]

****said: 554 5.7.1 This message is larger than the configured limit and has

****been blocked. (in reply to end of DATA command)

Eigentlich aber ist nach Postfixregeln und tausend verschiedenen Userforen alles richtig konfiguriert. Hierzu sind dann wohl die Auszüge aus der

Main.cf

alias_maps = hash:/etc/aliases

myorigin = domain.net

myhostname = emailgateway.domain.net

relay_domains = domain.de domain2.org

mynetworks = 127.0.0.0/8, XXX.XX.XXX.XX/XX

message_size_limit = 1048576000

local_transport = error:no local mail delivery

local_recipient_maps =

virtual_alias_maps = hash:/etc/postfix/virtual

relay_recipient_maps = hash:/etc/postfix/relay_recipients

transport_maps = hash:/etc/postfix/transport

recipient_delimiter =

smtpd_helo_required = yes

# smtpd_recipient_restrictions = reject_non_fqdn_sender, reject_unknown_sender_domain, permit_mynetworks, reject_unauth_destination, check_policy_service inet:127.0.0.1:60000, check_sender_access hash:/etc/postfix/access, permit

smtpd_recipient_restrictions = reject_non_fqdn_sender, reject_unknown_sender_domain, permit_mynetworks, reject_unauth_destination, check_sender_access hash:/etc/postfix/access, permit

smtpd_data_restrictions = reject_unauth_pipelining, permit

header_checks = pcre:/etc/postfix/header_checks

body_checks = pcre:/etc/postfix/body_checks

content_filter = smtp-amavis:[127.0.0.1]:10024

und der Master.cf nötig

#

# Postfix master process configuration file. For details on the format

# of the file, see the Postfix master(5) manual page.

#

# ==========================================================================

# service type private unpriv chroot wakeup maxproc command + args

# (yes) (yes) (yes) (never) (100)

# ==========================================================================

smtp inet n - - - - smtpd

#submission inet n - - - - smtpd

# -o smtpd_etrn_restrictions=reject

# -o smtpd_client_restrictions=permit_sasl_authenticated,reject

#smtps inet n - - - - smtpd

# -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes

#submission inet n - - - - smtpd

# -o smtpd_etrn_restrictions=reject

# -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes

#628 inet n - - - - qmqpd

pickup fifo n - - 60 1 pickup

-o content_filter=

-o receive_override_options=no_header_body_checks

cleanup unix n - - - 0 cleanup

qmgr fifo n - - 300 1 qmgr

#qmgr fifo n - - 300 1 oqmgr

tlsmgr unix - - - 1000? 1 tlsmgr

rewrite unix - - - - - trivial-rewrite

bounce unix - - - - 0 bounce

defer unix - - - - 0 bounce

trace unix - - - - 0 bounce

verify unix - - - - 1 verify

flush unix n - - 1000? 0 flush

proxymap unix - - n - - proxymap

smtp unix - - - - - smtp

# When relaying mail as backup MX, disable fallback_relay to avoid MX loops

relay unix - - - - - smtp

-o fallback_relay=

# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5

showq unix n - - - - showq

error unix - - - - - error

discard unix - - - - - discard

local unix - n n - - local

virtual unix - n n - - virtual

lmtp unix - - - - - lmtp

anvil unix - - - - 1 anvil

scache unix - - - - 1 scache

#

smtp-amavis unix - - - - 2 smtp

-o smtp_data_done_timeout=1200

-o smtp_send_xforward_command=yes

-o disable_dns_lookups=yes

#

127.0.0.1:10025 inet n - - - - smtpd

-o content_filter=

-o local_recipient_maps=

-o relay_recipient_maps=

-o smtpd_restriction_classes=

-o smtpd_helo_restrictions=

-o smtpd_sender_restrictions=

-o smtpd_recipient_restrictions=permit_mynetworks,reject

-o mynetworks=127.0.0.0/8

-o strict_rfc821_envelopes=yes

-o smtpd_error_sleep_time=0

-o smtpd_soft_error_limit=1001

-o smtpd_hard_error_limit=1000

-o receive_override_options=no_header_body_checks,no_unknown_recipient_checks

#

# ====================================================================

# Interfaces to non-Postfix software. Be sure to examine the manual

# pages of the non-Postfix software to find out what options it wants.

#

# Many of the following services use the Postfix pipe(8) delivery

# agent. See the pipe(8) man page for information about ${recipient}

# and other message envelope options.

# ====================================================================

#

# maildrop. See the Postfix MAILDROP_README file for details.

# Also specify in main.cf: maildrop_destination_recipient_limit=1

#

maildrop unix - n n - - pipe

flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}

#

# See the Postfix UUCP_README file for configuration details.

#

uucp unix - n n - - pipe

flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)

#

# Other external delivery methods.

#

ifmail unix - n n - - pipe

flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)

bsmtp unix - n n - - pipe

flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -d -t$nexthop -f$sender $recipient

scalemail-backend unix - n n - 2 pipe

flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}

Diese Zeile aus der main.cf

message_size_limit = 1048576000

sagt eigentlich aus das Mails bis zu der Größe in Byte durchkommen dürfen / sollen. Auch mit 0 (unendlich) haben wir das bereits versucht. Hilft aber auch nix.

Gegebenenfalls könnte noch wichtig sein das ein ClamAV, Spamassassin und ein Amavis läuft, aber auch bei Abschaltung scheint nur der Postfix den Fehler zu spucken.

Habt Ihr eine Idee woran das liegen könnte?

Viele Grüße

Onkel Hägi

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Guten Morgen zusammen,

vielen Dank an meinen Kollegen der mein Problem hier gepostet hat. Aktuell gibt es hier leider technische Probleme die ein weiterarbeiten an diesem Problem vorrübergehend nicht möglich macht.

Sobald ich an diesem Problem weiterarbeiten kann werde ich mich wieder mit euch in Verbindung setzen.

Vielen Dank soweit

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Öhm, Fehlermeldung mal genau durchgelesen?

Die besagt, das der Gateway die Mail blockt, da sie zu groß ist. Da kannst Du bei Deinem Postfix rumschrauben wie Du willst :)

Wie groß ist denn die Mail?

Er schreibt aber oben auch, dass
myhostname = emailgateway.domain.net

ist.

Einmal .net und einmal .de - evtl ist eins der beiden ja falsch. :rolleyes:

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi zusammen,

war nun zu allem Überfluss auch noch eine Weile krank, aber jetzt gehts weiter.

Wie groß ist denn die Mail?

Alles was größer ist als ~400kb scheint er nicht mehr zu mögen :(

Einmal .net und einmal .de - evtl ist eins der beiden ja falsch. :rolleyes:

Hm, wo genau? Bin das nun mehrfach durchgegangen und habe nix gefunden.

Ich hab hier zusätzlich einen Auszug aus dem /var/log/mail.log

betrifft eine "angeblich" zu große Email

Dec 8 15:02:14 emailgateway postfix/smtpd[2173]: connect from mail-in-02.arcor-online.net[151.189.21.42]

Dec 8 15:02:14 emailgateway postfix/smtpd[2173]: 6893C143A8: client=mail-in-02.arcor-online.net[151.189.21.42]

Dec 8 15:02:14 emailgateway postfix/cleanup[2176]: 6893C143A8: message-id=<3128157.1228744929045.JavaMail.ngmail@webmail09.arcor-online.net>

Dec 8 15:02:20 emailgateway postfix/smtpd[2173]: lost connection after DATA from mail-in-02.arcor-online.net[151.189.21.42]

Dec 8 15:02:20 emailgateway postfix/smtpd[2173]: disconnect from mail-in-02.arcor-online.net[151.189.21.42]

Nochmals danke für alle bisherigen Antworten und für alle die noch kommen werden.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gibts eventuell nen Cyrus, der dort läuft?

Zum Mailversenden gehören etliche Config-Files, nicht nur die main.cf und master.cf.

relevant sind auch:

amavis.conf

cyrus.conf

smtpd.conf

Du musst mal genauer werden, welche Dienste alle im Zusammenhang mit Mail laufen. Wie gesagt Cyrus vielleicht, Amavis meintest du ja schon usw... Hängt das alles hinter nem Router, der vielleicht gewisse Dateigrößen blockt?

Paar mehr Loginformationen wären auch hilfreich. Also mal das Loglevel hochsetzen, damit da mehr rumkommt.

EDIT: Laut Log von oben, hast du Probleme beim Empfang. Wie siehts denn mit senden aus?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

So, da bin ich wieder.

Konnte das Problem nun selbst beheben. Mein Kollege hatte eine versteckte Firewall-Regel aktiv welche Emails die größer als 1 MB sind komplett geblockt hat.

Relativ ärgerlich, wenn man betrachtet wieviel Zeit das gekostet hat^^

Vielen Dank nochmal für eure Mühe

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nimm an der Diskussion teil

Du kannst jetzt hier posten und Dich später registrieren. Wenn Du bereits über eine Konto verfügst, melde Dich jetzt an, um mit Deinem Konto zu posten.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


Fachinformatiker.de, 2020 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung