Jump to content

html5 required-Attribut nutzen

Empfohlene Beiträge

Hallo zusammen,

nutzt ihr bereits das required-Attribut bei input-Feldern oder prüft ihr lieber mit JS ob das Feld befüllt ist? Ich würde das Attribut sehr vorsichtig nutzen, denn nicht alle Browser unterstützen es immer noch. Oder was denkt ihr?

Apropos. Kenn ihr gute deutsche Foren für Web-Entwickler?

Vielen Dank.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Am 26.1.2015 um 23:25 schrieb vinslave:

Ich würde das Attribut sehr vorsichtig nutzen, denn nicht alle Browser unterstützen es immer noch.

Würde ich von der Zielgruppe abhängig machen. Wenn es um Businesszeugs geht und in Behörden oder ähnlichem damit gearbeitet wird, kann man es noch mit älteren Browsern zu tun haben.

Bei den ganz normalen Internet-Usern nehme ich auf sowas weniger Rücksicht. Siehe Musashi.

Am 26.1.2015 um 23:25 schrieb vinslave:

Apropos. Kenn ihr gute deutsche Foren für Web-Entwickler?

Kommt drauf an was gut bedeutet^^ Aber erstmal kann ich das hier empfehlen: https://www.fachinformatiker.de :ph34r:

Ansonsten bin ich viel auf php.de unterwegs gewesen, da ist der Ton manchmal etwas rauer, je nachdem wie man seine Fragen stellt und wie viel Mühe man zeigt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich nutze es meistens/immer in Verbindung mit parsley.js oder einem shim + serverseitige Überprüfung natürlich.

Grund dafür: https://caniuse.com/#search=required

IE8/IE9 und Safari 10 kennen required nicht und sind leider immer noch bei genug Nutzern der Standardbrowser.

Am 26.1.2015 um 23:25 schrieb vinslave:

Apropos. Kenn ihr gute deutsche Foren für Web-Entwickler?

Tatsächlich ist es mit deutschen Foren etwas schwer - ich kenne für Entwicklung auf Deutsch tatsächlich nur das Unterforum von netcup: https://forum.netcup.de/entwicklung-der-eigenen-webseite/ 

Ich bin meistens auf stackoverflow.com und bekomme dort die besten antworten und helfe natürlich selbst mit.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 3 Stunden schrieb gab3:

IE8/IE9 und Safari 10 kennen required nicht und sind leider immer noch bei genug Nutzern der Standardbrowser.

Man sollte natürlich auch seine Zielgruppe kennen und je nachdem, was die (zB. Analytics-)Daten hergeben, weiß man ja, ob ein paar Prozent noch den IE8/9 nutzen und ob es sich (wirtschaftlich, Kosten/Nutzen) lohnt, diese Browser noch zu unterstützen.

Was man aber immer(!) trotzdem machen muss, ist eine serverseitige Überprüfung der Daten.

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nimm an der Diskussion teil

Du kannst jetzt hier posten und Dich später registrieren. Wenn Du bereits über eine Konto verfügst, melde Dich jetzt an, um mit Deinem Konto zu posten.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


Fachinformatiker.de, 2019 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung