Jump to content

Empfohlene Beiträge

Hi,

ich hoffe, dass ich hier richtig bin.

Mein htaccess funktioniert nicht.

Ich habe eine Datei .htaccess:


AuthUserFile HabelStat/html/.htpasswd

AuthType Basic

AuthName "Secure"

require valid-user

und eine 2. Datei .htpasswd:

admin:xxxx

Ich habe die beiden Dateien in das zu schützende Verzeichnis gelegt.

Wenn ich die Seite öffne, die geschützt sein soll, sollte ja eigentlich eine Abfrage kommen. Da passiert aber nichts, ich kann mir die Seite ganz normal anzeigen lassen, ohne aufgefordert zu werden ein Passwort und einen Benutzer einzugeben.

Ist an den Dateien was falsch?

Liegen Sie am falschen Platz?

Oder muss ich noch was in meinem Apache einstellen?

Bisher habe ich immer einen eigenen Passwort Generator verwendet. Jetzt ist aber eine Lösung mit htaccess gewünscht. Ich hab mich da dann mal informiert, wie das funktioniert und hab das dann so realisiert. Allerdings weiß ich jetzt nicht wo der Fehler liegen soll.

Danke und MfG

korea1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

danke für die schnelle Antwort.

Wenn ich diese Zeile in meine conf - Datei einfüge, startet der Apache nicht mehr. AllowOverride AuthConfig

Kann die Zeile nicht kopiert werden und dort einfach eingefügt werden?

Wo sollte man die .passwd ablegen?

Danke und MfG

korea1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wenn ich diese Zeile in meine conf - Datei einfüge, startet der Apache nicht mehr. AllowOverride AuthConfig

Kann die Zeile nicht kopiert werden und dort einfach eingefügt werden?

Wo sollte man die .passwd ablegen?

Wohin du die kopieren musst findest du hier:

http://httpd.apache.org/docs-2.1/mod/core.html#allowoverride

und die .htpasswd legst du irgendwohin. z.B. ausserhalb des Webpfads.

Achja, die Angabe zum htpasswd File in der htaccess Datei muss den PFad vom Serverroot enthalten.

Also z.B.

/var/www/MeineDomain/.htpasswd

nicht nur ./.htpasswd

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Directive existiert schon, du musst sie nur anpassen:

#

# This controls which options the .htaccess files in directories can

# override. Can also be "All", or any combination of "Options", "FileInfo",

# "AuthConfig", and "Limit"

#

AllowOverride None

Wo sollte man die .passwd ablegen?

relativ egal, nur nicht von außen erreichbar...

Gruß Jaraz

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nimm an der Diskussion teil

Du kannst jetzt hier posten und Dich später registrieren. Wenn Du bereits über eine Konto verfügst, melde Dich jetzt an, um mit Deinem Konto zu posten.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


Fachinformatiker.de, 2019 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung