Zum Inhalt springen

vServer einrichten (Apache/PHP/MySQL/Plesk)


Empfohlene Beiträge

Hi,

ich soll einen vServer mit Debian 3.1 (sarge), Apache2.2.[neu], PHP5.2.[neu] und MySQL5.0.[neu] einrichten.

Soweit so gut. Blos jetzt kommt das unschönste. Mit Plesk8.2.0.

Kann mir jemand eine Anleitung geben, wie ich die Komponenten zusammenbringe?

Ich habe selber einen mServer mit (fast) den selben Komponenten (PHP5.1.x). Ich blicke durch diese "Pleskstruktur" nicht durch.

Wenn möglich bitte von $NULL an. Beziehungsweise ist Debian bereits installiert und fertig.

Ich habe es versucht mit der "normalen" Installation ($/lib jetzt mal ausßen vor)

/server/apache/...

/server/php/...

/server/mysql/...

Hat auch super geklappt. Blos Plesk weigert sich die Komponenten anzuerkennen.

Bitte keine Kommentare wie lass Plesk weg - ist nen Sicherheitsproblem. Weiß ich selber aber es ist eben nun mal vorgabe :(

Link zu diesem Kommentar
Auf anderen Seiten teilen

Hi,

ich habe mich noch etwas umgesehen und folgendes gefunden: Forenübersicht - debian - php5 - mysql

Nur habe ich da noch ein paar Probleme:

[B]apt-get install libapache2-mod-php5[/B]

Reading Package Lists... Done

Building Dependency Tree... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.


Since you only requested a single operation it is extremely likely that

the package is simply not installable and a bug report against

that package should be filed.

The following information may help to resolve the situation:


The following packages have unmet dependencies:

  libapache2-mod-php5: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed

                       Depends: libdb4.4 but it is not installable

                       Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed

                       Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable

                       Depends: libxml2 (>= 2.6.27) but 2.6.16-7 is to be installed

E: Broken packages
[B]apt-get upgrade libc6[/B]

Reading Package Lists... Done

Building Dependency Tree... Done

libxml2 is already the newest version.

0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.

v32511:~# apt-get upgrade libc6

Reading Package Lists... Done

Building Dependency Tree... Done

The following packages have been kept back:

  libapache2-mod-php4 php4 php4-cgi php4-cli php4-common php4-curl php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear

  php4-recode php4-snmp php4-sybase php4-xslt

0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
[B]apt-get upgrade libc6[/B]

Reading Package Lists... Done

Building Dependency Tree... Done

The following packages have been kept back:

  libapache2-mod-php4 php4 php4-cgi php4-cli php4-common php4-curl php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear

  php4-recode php4-snmp php4-sybase php4-xslt

0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.

v32511:~# apt-get install libdb4.4

Reading Package Lists... Done

Building Dependency Tree... Done

Package libdb4.4 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

E: Package libdb4.4 has no installation candidate
[B]apt-get upgrade libkrb53[/B]

Reading Package Lists... Done

Building Dependency Tree... Done

The following packages have been kept back:

  libapache2-mod-php4 php4 php4-cgi php4-cli php4-common php4-curl php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear

  php4-recode php4-snmp php4-sybase php4-xslt

0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
[B]apt-get install libssl0.9.8[/B]

Reading Package Lists... Done

Building Dependency Tree... Done

Package libssl0.9.8 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

E: Package libssl0.9.8 has no installation candidate
[B]apt-get upgrade libxml2[/B]

Reading Package Lists... Done

Building Dependency Tree... Done

The following packages have been kept back:

  libapache2-mod-php4 php4 php4-cgi php4-cli php4-common php4-curl php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear

  php4-recode php4-snmp php4-sybase php4-xslt

0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.

Link zu diesem Kommentar
Auf anderen Seiten teilen

ich soll einen vServer mit Debian 3.1 (sarge), Apache2.2.[neu], PHP5.2.[neu] und MySQL5.0.[neu] einrichten.

Was für Backports hast du denn in deine sources.list eingetragen? Die sollten die Konflikte doch auflösen.

Sarge unterstützt von sich aus weder Apache 2.2, noch php5.2, noch mySQL5.

home [Dotdeb]

Da findest du z.B. die o.g. Pakete für Sarge.

Oder du nimmst Etch, aber bei einem vServer wird das nicht so einfach gehen. Vielleicht bietet dein Provider das ja an und du kannst das Paket einfach wechseln.

EDIT:

Wie du das aber in Plesk einbindest hab ich keine Ahnung. Ist es nicht so, dass du da spezielle Plesk-Pakete brauchst, und nicht einfach die Distributions-Installation nutzen kannst?

Link zu diesem Kommentar
Auf anderen Seiten teilen

Dein Kommentar

Du kannst jetzt schreiben und Dich später registrieren. Wenn Du ein Konto hast, melde Dich jetzt an, um unter Deinem Benutzernamen zu schreiben.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung wiederherstellen

  Nur 75 Emojis sind erlaubt.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

 Teilen

Fachinformatiker.de, 2022 by SE Internet Services

fidelogo_small.png

Schicke uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App

Download on the App Store
Get it on Google Play

Kontakt

Hier werben?
Oder sende eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung