Zum Inhalt springen

Fighter456

Mitglieder
  • Gesamte Inhalte

    2
  • Benutzer seit

  • Letzter Besuch

  1. Guten Abend, da stundenlange Recherche im Internet leider nicht zum gewünschten Erfolg geführt hat, versuche ich mein Problem mal darzulegen und vielleicht die Lösung für mein Problem zu bekommen. Vorab einmal die Rahmenbedingungen: (bintec) be.IP Plus als Router (192.168.1.254) Hauptnetz: 192.168.1.0/24 (was die be.IP verwaltet) Zweitnetz: 192.168.2.0/24 (was ein weiterer Router (192.168.2.254) verwaltet) (bintec) Secure IPsec Client Die be.IP ist direkt über ein LAN-Kabel mit einem Switch verbunden, wo auch der Router des zweiten Netzes direkt angeschlossen ist. Die LAN-Schnittstelle der be.IP hat die IP-Adressen 192.168.1.254 und 192.168.2.253 zugewiesen. Ein Ping auf den Router des Zweitnetzes über "Wartung --> Diagnose" funktioniert auch problemlos, weshalb davon auszugehen ist (und ich auch überzeugt bin), dass das Zweitnetz für die be.IP ansprechbar ist. Mein Problem: Über einen VPN-Einwahlzugang welcher in der be.IP eingerichtet ist verbindet sich mein Endgerät mit Hilfe des Secure IPsec Clients mit dem Hauptnetz. Mit Hilfe der "Split Tunneling" - Einstellung wird gesteuert das auch nur das entsprechende Netz über den VPN geroutet wird. Dies funktioniert auch problemlos. Nun will ich über den VPN auch direkten Zugriff auf das Zweitnetz haben. Defacto habe ich die "Split Tunneling" - Einstellung im VPN-Client um das Zweitnetz erweitert und via "tracert" überprüft ob entsprechende Anfragen über den VPN versucht werden zu routen. Leider bricht die Routenverfolgung am Router des Hauptnetzes ab. Er weiß anscheinend nicht was er damit anfangen soll und verwirft die Anfrage. Über "Netzwerk --> Routen" habe ich bereits versucht dem Router klarzumachen, das er Anfrage an die an meiner VPN-Schnittstelle für das Netz 192.168.2.0/24 über die lokale LAN-Schnittstelle (LAN_EN1-0) leiten soll. Routentyp: Netzwerkroute via Schnittstelle Schnittstelle: LAN_EN1-0 Routenklasse: Erweitert Ziel-IP-Adresse/Netzmaske: 192.168.2.0 / 24 Lokale IP-Adresse: 192.168.1.254 Quellschnittstelle: IPSEC_Test Quell-IP-Adresse / Netzmaske: 0.0.0.0 / 24 Layer 4 - Protokoll: Beliebig Quellport: Beliebig Zielport: Beliebig DSCP/TOS-Wert: Nicht beachten Modus: Wählen und warten Hat jemand so ein Vorhaben bereits erfolgreich in die Tat umgesetzt, sieht meinen Fehler und kann mir einen Denkanstoß für den richtigen Lösungsweg geben? Vielen Dank!
  2. Hallo zusammen, in der Hoffnung, hier eine Lösung für mein Problem zu finden, wende ich mich nun an euch. Es geht darum, dass ich mir ein kleines Programm in C# geschrieben habe, welches die Möglichkeit bietet, Standbilder von der aktuellen Aufnahme einer Kamera zu erstellen. Benutzt wird die „DirectX.Captureâ€-Schnittstelle. Dies funktioniert unter einen reinen Windows-Umgebung mit direkt angeschlossener Kamera problemlos. Jetzt habe ich allerdings das Problem, dass ich dieses Programm auch unter einer Citrix-Umgebung benutzen möchte. Die Citrix-Sitzung wird auf meinem lokalen Computer gestartet, wo ich die entsprechende Kamera angeschlossen habe. Der Übernehmen der Kamera in die Sitzung als "Citrix HDX Web Camera" funktioniert problemlos. Die Funktionalität der Kamera habe ich in Skype getestet. Der Aufruf bzw. die Initialisierung der Kamera in meinem Programm sieht folgendermaßen aus: private void InitializeCaptureDevice() { try { this.mFilters = new Filters(); this.mCaptureDevice = new Capture(this.Filters.VideoInputDevices[int.Parse(ConfigurationManager.AppSettings["videodevice"])], null); string[] resolution = ConfigurationManager.AppSettings["auflösung"].Split('x'); this.CaptureDevice.FrameSize = new Size(int.Parse(resolution[0]), int.Parse(resolution[1])); this.CaptureDevice.FrameRate = 15; this.CaptureDevice.PreviewWindow = this.Preview; this.CaptureDevice.FrameCaptured += new Capture.FrameCapturedHandler(CaptureDevice_FrameCaptured_Flipping); this.CaptureDevice.CaptureFrame(); } catch (Exception e) { MessageBox.Show("Fehler bei der Initialisierung aufgetreten:\r\n" + e.Message, this.Text, MessageBoxButtons.OK, MessageBoxIcon.Error); this.Close(); } } Nun bekomme ich durch die Ausgabe in der MessageBox die Meldung . Der Stacktrace zeigt, dass er bei this.CaptureDevice.FrameSize = new Size(...); hängen bleibt. Kommentiert man diese Zeile aus, hängt er erneut in darauffolgenden Zeile, mit der selben Fehlermeldung. „this.CaptureDevice†ist im Übrigen eine Instanz von „DirectX.Capture.Captureâ€. „this.Filter†von „DirectX.Capture.Filtersâ€. Hat jemand von euch soetwas schon umgesetzt und eventuell einen Lösungsansatz parat? Ist mein Vorhaben überhaupt möglich? Mit freundlichen Grüßen Fighter456

Fachinformatiker.de, 2020 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung