Zum Inhalt springen

debian lenny apache subdomain zeigt immer auf hauptdomain


Empfohlene Beiträge

hallo zusammen.

ich bin gerade etwas am verzweifeln... :(

und zwar wird beim aufruf von bla.meinedomain.de immer der inhalt aus meinedomain.de angezeigt.

folgendes szenario: ich habe bei united-domains ne domain registriert.

die zeigt auf die ip meines root-servers.

der root ist frisch aufgesetzt. dort läuft nur mysql, apache2, und php5

in der default.conf habe ich mir 2 vhosts eingerichtet.

einer zeigt auf /var/www/ und einer auf /var/www/bla/

das ganze sieht so aus:


NameVirtualHost *:80

<VirtualHost *:80>

DocumentRoot /var/www/

ServerName meinedomain.de

ServerAlias meineip

</VirtualHost>


<VirtualHost *:80>

#<VirtualHost bla.meinedomain.de:80>

DocumentRoot /var/www/bla/

ServerName bla.meinedomain.de

</VirtualHost>

bei united-domains habe ich nun die wildcard funktion für subdomains aktiviert, sodass alle subdomain url's auf die ip weitergeleitet werden.

mein apache müsste doch nun unterscheiden können, welchen

vhost er nutzen soll oder?

oder verstehe ich die wildcard funktion falsch?

vg

afr0

Link zu diesem Kommentar
Auf anderen Seiten teilen

hallo und sorry für den doppelpost, sowie dass ich glatt vergessen habe euch nachträglich allen ein frohes neues zu wünschen :D

ich glaube ich habe gerade meinen fehler gefunden.

und zwar muss ich gestern nacht wohl unter zu wenig kaffezufuhr auf die blöde idee gekommen sein den a-eintrag der domain auf die standarserver von united domains zu stellen... :upps: :floet:

mal sehen ob es anchher wieder läuft :D

vg afro

Link zu diesem Kommentar
Auf anderen Seiten teilen

schau Dir an, ob Du mit dieser Konfiguration VirtualHost Examples - Apache HTTP Server übereinstimmst.

Wenn ich Dich verstehe, machst Du ja eine Weiterleitung und das wird wohl nicht funktionieren, denn damit ein VHost funktioniert muss die Domain im HTTP Header übergeben werden. Je nachdem wie nun United Domains das konkret umsetzt, kann das nicht klappten.

Um so etwas eigentlich richtig einzurichten ändert man einfach den A Record des DNS auf die passende IP

Link zu diesem Kommentar
Auf anderen Seiten teilen

hi flashpixx,

danke für den link, den hab ich gestern nacht schon rauf und runter gebetet und bin echt schon vom glauben abgekommen :D

als ich vorhin meine domain angepingt habe kam es mir einfach komisch vor, dass der ping zu united domains geht... da wurde mir klar, dass mit dem a-eintrag was nicht stimmen kann :)

danke trotzdem

afro

Link zu diesem Kommentar
Auf anderen Seiten teilen

als ich vorhin meine domain angepingt habe kam es mir einfach komisch vor, dass der ping zu united domains geht... da wurde mir klar, dass mit dem a-eintrag was nicht stimmen kann :)

Bieg einfach den A Record auf Deinen Server, dann sollte es auch klappten (sofern die Konfig stimmt, aber da habe ich jetzt keinen Fehler gesehen)

Link zu diesem Kommentar
Auf anderen Seiten teilen

Deine Meinung

Schreibe jetzt und erstelle anschließend ein Benutzerkonto. Wenn Du ein Benutzerkonto hast, melde Dich bitte an, um unter Deinem Benutzernamen zu schreiben.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung wiederherstellen

  Nur 75 Emojis sind erlaubt.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

 Teilen

Fachinformatiker.de, 2021 by SE Internet Services

fidelogo_small.png

Schicke uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App

Download on the App Store
Get it on Google Play

Kontakt

Hier werben?
Oder sende eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung