Zum Inhalt springen

LouisCy

Mitglieder
  • Gesamte Inhalte

    26
  • Benutzer seit

  • Letzter Besuch

Letzte Besucher des Profils

Der "Letzte Profil-Besucher"-Block ist deaktiviert und wird anderen Benutzern nicht angezeit.

  1. So hatte jetzt biischen viel um die Ohren und kann jetzt gerade bisschen basteln. Erstmal Danke für die Tipps. Was ich vermutlich falsch verstehe -> ist das native VLAN das VLAN 1 (default)? Wenn dem so sein sollte, dachte ich, ich soll VLAN1 nicht benutzen. Ich hätte jetzt vermutlich Port 1 & 2 als WAN ( VLAN 100) konfiguriert und da den RasPi und ISP Router angeschlossen um durchzureichen. Ist das sinnvoll? Auf dem OpenWRT soll ja früher oder später noch OpenVPN und auch AdGuard( o. ä. ) laufen. sollte ich das jetzt in der VLAN Konfig. schon berrücksichtigen? grüße Lou.
  2. Naja eigentlich sollte dir das Buch von Reinwerk ja schon "ausreichend" Kenntnis vermitteln. Vllt hast du auch selbst schon dran gedacht, aber bei Youtube findest du ganze Semster an Vorlesungen inklusive Übungen zu relationalen Datenbanken oder auch wenn du da kein Bock hast einfache Tutorials zu den Must have Sachen. Generell lohnt sich auch mal ein Blick in MariaDB/MongoDB etc.
  3. Der Switch sprach nun doch DHCP und ein erneuter Factory Reset hat nun auch endlich ne IP hinterm Ofen vor gelockt. Das heißt ich kann endlich die Default Konfig einsehen. switch ohne OpenWRT Pi und nochmal zur Übersicht die bereits oben geposteten Infos PC OpenWRT Wie sollte ich jetzt am schlausten vorgehen um mein ursprüngliches anliegen umzusetzen? Also die im 1. Schritt in der Topologie gezeigten Vlans zu realisieren?
  4. da hast du leider recht. Zwar hat auch der vorbesitzer gemeint das die IP vom DHCP zugewiesen wird, aber das tut sie nicht. Ich bin ja wie gesagt im Netzwerkthema nicht sehr bewandert, aber kann mir wer sagen, weshalb es nicht funktioniert dem switch über den ISP Router eine statische IP zuzuweisen und dann damit das WebInterface anzusprechen? Noch eine Noobfrage bezüglich : Mit einem normalen Micro-USB zu USB geht es nicht oder ? : ) genau. Der hat 192.168.0.1 du fragst dich sicher, wieso ich dann in der WRT config, diese eingetragen habe? Ja das tue ich auch. ich hab scheinbar falsch gecopied.
  5. Findest du? Ich kann mir gerade nur schwer vorstellen sowas wie Vererbung oder ADT umzusetzen. Kannst du nochmal erläutern inwiefern die Datenkapselung kaputtgeht, wenn sie in der .h definiert wird oder meinst du das Geheimnisprinzip?
  6. @Finux heißt das du hast es jetzt verstanden? Falls nicht, schau dir nochmal das Prinzip der Modularisierung an. OOP versucht ja die Daten bestmöglich zu kapseln. Damit werden Sie auch wiederverwendbar und du brauchst dich nicht zu wiederholen und die Abhängigkeiten minimieren sich, bzw. spielen bestenfalls keine Rolle mehr.
  7. Ich sehe gerade die hier eingetragene IP stimmt ja garnicht, bei mir ist es die default ip 192.168.1.1 hatte die config ursprünglich so abgespeichert, deswegen hier die Abweichung...
  8. @Crash2001 also, da hast du natürlich recht. Ich dachte kurz ich hätte ja alles default gelassen, aber das stimmt ja garnicht. Da das switch gebraucht gekauft wurde und ich mich nach wie vor nicht verbunden bekomme, weiß ich zu dieser config nix zu sagen. Bei OpenWrt hab ich diese config: config interface 'lan' option type 'bridge' option ifname 'eth0' option proto 'static' option ipaddr '192.168.1.99' option netmask '255.255.255.0' option gateway '192.168.1.254' option dns '1.1.1.1' wenn ich am Desktop das Gateway und DNS auslese, zeigt er mir '192.168.1.1' also OpenWrt an. GENERAL.TYPE: ethernet GENERAL.HWADDR: 00:D8:42:55:19:16 GENERAL.MTU: 1500 GENERAL.STATE: 100 (verbunden) GENERAL.CONNECTION: Kabelgebundene Verbindung 1 IP4.ADDRESS[1]: 192.168.1.221/24 IP4.GATEWAY: 192.168.1.1 IP4.ROUTE[1]: dst = 0.0.0.0/0, nh = 192.168.1.1, mt = 20100 IP4.ROUTE[2]: dst = 192.168.1.0/24, nh = 0.0.0.0, mt = 100 IP4.ROUTE[3]: dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000 IP4.DNS[1]: 192.168.1.1 Zu den Problem mit der Switch Config. gibts noch irgendeine Möglichkeit ohne das serielle Kabel zuzugreifen, da ich keins da habe und auch für einen Zugriff keins kaufen will. Die Topo ist angehangen. grüße Lou topo.pdf
  9. Also ich habe jetzt ein switch gekauft. Es ist ein HP Aruba 2530 geworden. Ich habe heute versucht die auf das Interface des switches zuzugreifen und bin kläglich gescheitert. Als erstes habe ich versucht mir die IP über den ISP Router anzeigen zu lassen, da hat es zwar das Gerät gefunden, aber es hat keine IP bekommen. Dann nochmal über die Konsole vom verbunden Linux Rechner mit ip addr da kam aber auch nix raus. Kann sich jemand vorstellen, wieso der keine bekommen hat? zum zweiten Phänomen. Ich hab an das switch probeweise schonmal den OpenWrt RasPi angeschlossen und konnte nach einiger bootzeit und reboot des ISP Routers auch per SSH zugreifen. Als er den OpenWrt gefunden hat, gab es allerdings wieder Probleme mit dem Netz vom Desktop aus, wie oben schonmal beschrieben. Also YT, Wikipedia, heise.de waren erreichbar, aber der ISP router über den browser nicht und auch Seiten wie die Lokalpresse oder das Forum hier nicht. ich hab dann vom desktop versucht den ISP router anzupingen da kam das bei raus xxx@xxx:~$ ping 192.168.0.1 PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data. From 192.168.1.1: icmp_seq=2 Redirect Host(New nexthop: 192.168.1.254) From 192.168.1.1 icmp_seq=1 Destination Host Unreachable From 192.168.1.1 icmp_seq=2 Destination Host Unreachable From 192.168.1.1 icmp_seq=4 Destination Host Unreachable From 192.168.1.1 icmp_seq=5 Destination Host Unreachable From 192.168.1.1 icmp_seq=6 Destination Host Unreachable ^C --- 192.168.0.1 ping statistics --- 8 packets transmitted, 0 received, +5 errors, 100% packet loss, time 7154ms pipe 3 und das gleiche von OpenWrt zum ISP Router root@OpenWrt:~# ping 192.168.0.1 PING 192.168.0.1 (192.168.0.1): 56 data bytes ^C --- 192.168.0.1 ping statistics --- 5 packets transmitted, 0 packets received, 100% packet loss Kann mir jemand erklären was da schief läuft?
  10. Okay. Also ich muss mich jetzt zwischen dem SG250 und dem HPE entscheiden. Mit dem hint auf das OS tendiere ich stark dazu. PoE würde ich noch geil finden, aber das schiebt den Preis leider gleich im 100€ an.
  11. Okay, gern. ich melde mich bei dir sobald ich einen switch da habe.
  12. mhh, cisco SG-350 finde ich jetzt gerade auch bisschen zu preisintensiv. was haltet ihr von diesem? die sind alle managed und mit PoE, was mir wichtig ist. Was noch cool zu wissen wäre, wie laut Sie sind, falls mit Lüfter. Weiß da jemand zufällig was? https://geizhals.de/ubiquiti-unifiswitch-8-desktop-gigabit-managed-switch-us-8-a1557156.html?hloc=at&hloc=de https://geizhals.de/cisco-sg250-desktop-gigabit-smart-switch-sg250-08-k9-a1790983.html?hloc=at&hloc=de https://geizhals.de/zyxel-gs1200-desktop-gigabit-smart-switch-gs1200-8hpv2-eu0101f-a1880060.html?hloc=at&hloc=de
  13. Nee noch nicht. Ich wollte schonmal den Pi konfigurieren bis der Switch da ist.
  14. Nach dem letzten Neustart vom ISP Router lief es dann und ich kann per SSH drauf. Ich hab allerdings jetzt noch ein anderes Problem was mich vom weitermachen abhält. Sobald ich den openwrt Pi an den Router hänge, "spinnt " das Netz. Ich kann am Rechner nur noch auf große Seiten( YT, Wikipedia, Google) zugreifen. Die lokale Presse oder auch duckduckgo bekommen keine Verbindung. Liegt das am DNS ? Dazu kommt , wenn ich per ssh im OpenWRT drin bin, ich auch keine Verbindung zum Netz habe, also Pingen von 8.8.8.8 oder google.com werden nicht beantwortet. Weiß wer an welcher Schraube ich noch drehen muss?
  15. Ich hab das Image jetzt auf dem Pi. Zumindest gehe ich davon aus. Mit ssh root@192.168.1.1 bekomme ich keine Verbindung. Ich habe das /etc/config/network schon über die SD angepasst, aber die IP steht da auch so drin. Ich hatte den Pi schonmal vorher irgendwann über den Router statisch zu gewiesen. Hab ich aber rausgelöscht. Woran kann das noch liegen? @FBDIMM

Fachinformatiker.de, 2021 by SE Internet Services

fidelogo_small.png

Schicke uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App

Download on the App Store
Get it on Google Play

Kontakt

Hier werben?
Oder sende eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung