Zum Inhalt springen
Melde dich an, um diesem Inhalt zu folgen  

Problem beim Einrichten von Icingaweb2

Empfohlene Beiträge

Hallo Leute,

ich habe ein Problem beim einrichten von Icingaweb2.

Und zwar habe ich auf einem Ubuntu Server 14.4.3 nach dieser Anleitung zuerst Icinga2 und danach die Webapplikation installiert, die Datenbank erstellt und konfiguriert.

Soweit so gut.

Allerdings bekomme ich bei der abschließenden Konfiguration über das Webinterface nicht weiter. Beim Schritt "IDO Ressource definieren und überprüfen lassen" folgende Fehlermeldung

Zitat

Die Validierung der Konfiguration ist fehlgeschlagen: Connection failed SQLSTATE[28000] [1045] Access denied for user 'icingaweb'@'localhost' (using password: YES)

Wenn ich mir die Rechte des Benutzers anschaue, hat er aber alles was er braucht (zumindest laut Anleitung).

Da ich von Linux bis jetzt ungefähr so viel Ahnung habe wie ein Fisch vom Fahrradfahren (Entschuldigung an alle Fahrrad fahrenden Fische), habe ich keinen Anhaltspunkt wo ich mit der Fehlersuche ansetzen soll.

Ich gehe mal davon aus, dass es irgendwas komplett idiotisch-simples ist und ich den Wald vor lauter "dadd is keen Fenster, datt kannste nüscht" nicht sehe.

Und bevor einer Fragt: Ja, die Dienste habe ich neu gestartet.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ok, Problem gelöst.

Anwenderfehler.

Ich ging davon aus, dass schon im Schritt "Datenbankressource festlegen und überprüfen lassen" das Kennwort des icingaweb Benutzers überprüft wird. Dem ist nicht so, man kann hier als Passwort alles Mögliche eintragen ohne dass gemeckert wird.

Ich habe das Passwort des Users zurückgesetzt und nun gehts.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Soweit ich mich richtig erinnere habe ich bei dem Punkt "Datenbankressource festlegen und überprüfen lassen" ein falsches Kennwort eingegeben.

Da anscheinend hier das Kennwort nicht überprüft wurde, wurde es logischerweise nicht als flasch angemeckert.

Ich hab dann das Kennwort des Benutzers zurückgesetzt und mit dem neuen Kennwort ging es dann. Ob sich hier durch die Versionen etwas getan hat kannst du ja mal prüfen indem du "Blödsinn" als Kennwort nimmst, wenn hier auch nicht gemeckert wird, liegt es am Kennwort.

ansonsten würde ich dich eher ins Icingaforum schicken, da treiben sich auch die Entwickler rum und können bei komischen Problemen helfen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Öhm...

Ich glaube ich habe mich auf der Console als root am mysql server angemeldet und das Kennwort des Users neu gesetzt http://www.sysadminslife.com/linux/mysql-user-passwort-aendern/

Dafür muss man natürlich als root in die Datenbank kommen und wissen welcher User ein neues PW benötigt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Deine Meinung

Du kannst jetzt schreiben und Dich später registrieren. Wenn Du ein Konto hast, melde Dich an , um mit Deinem Konto zu schreiben.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Nur 75 Emojis sind erlaubt.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

Melde dich an, um diesem Inhalt zu folgen  

Fachinformatiker.de, 2020 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung