Jump to content
Melde dich an, um diesem Inhalt zu folgen  

WSUS Serverknoten entkonten

Empfohlene Beiträge

Hallo zusammen,

mein WSUS (Windows Server 2012 (ohne R2) ) treibt mich gerade zur Verzweiflung.

angefangen hat das ganze vor ein paar Monaten als immer öfter der Fehler:

Die WSUS-Verwaltungskonsole konnte über die Remote-API keine Verbindung mit dem WSUS-Server herstellen.
Stellen Sie sicher, dass der Update Services-Dienst, IIS und SQL auf dem Server ausgeführt werden. Starten Sie IIS, SQL und den Update Services-Dienst erneut, wenn das Problem weiterhin besteht.
System.Net.WebException -- Fehler bei der Anforderung mit HTTP-Status 503: Service Unavailable.

Da dieser Fehler im Zusammenhang mit Problem bei der Serverbereinigung aufgetreten ist, habe ich diese Anleitung hier befolgt (für die die nicht Klicken wollen: in der internen Datenbank das klemmede Update manuell rauswerfen), was auch kurzzeitig (2-3 Wochen) etwas gebracht hat. Danach wieder bei gefühlt jedem zweiten Klick in der Konsole "Serverknoten zurücksetzen".

Also war das nicht der Fehler. Ok, weiter Tante Google gefüttert, den WSUS komplett zurückgesetzt, 3 Tage Ruhe, danach wieder "Serverknoten zurücksetzen". Yay -.-

Also wieder das selbe Problem, diesmal so krass, dass ich die Maschine neu starten muss um wieder einen WSUS zu haben. Nicht praktikabel. Also habe ich diese Maschine Anfang der Woche weggeschmissen und mit dem selben Namen und der selben IP etc. neu aufgesetzt. WSUS Dienst installiert, erste Synchronisation angeworfen, dann noch mal Produkte und Klassifizierungen hinzugefügt, noch mal synchronisieren lassen. Dann den WSUS auf sich selbst nach Updates suchen lassen (Neuinstallation halt) und zack "Serverknoten zurücksetzen". Also wieder Google, das hier gefunden (Updatenacharbeiten bei KB KB3148812 und/oder KB3159706) und gemacht, bringt aber nichts.

Also Datenbank zurücksetzten, Updatenacharbeiten, zurücksetzen und Neuinstallation der kompletten Maschine versucht, nichts hat den Fehler weggehalten. Was tun? Was mache ich falsch/habe ich übersehen? Wie bekomme ich wieder einen zuverlässigen Updateserver?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ähnliche Problem hatten wir bei uns auch, welche uns zwar nicht komplett ums Leben gebracht haben da wir als Folge dann 3 Wochen später von 2012 auf 2016 gewechselt haben, jedoch haben wir uns natürlich trotzdem drum gekümmert gehabt.

Hast du bei dir im Netzwerk einen einzelnen WSUS oder hast du möglicherweise weitere, sodass sich z.B. auch eine Replizierung ereignet?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe aktuell nur den einen, bei < 200 Clients an einem einzelnen Standort sollte der reichen :)

Waren bei euch die Probleme nach der Migration auf 2016 weg? Das wäre nämlich nicht das Problem, die Lizenz wäre vorhanden.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ok, so wie es ausschaut hat auch ein Umzug auf Server 2016 (gestern durchgeführt) nichts gebracht, ich habe das selbe Verhalten jetzt heute morgen wieder. Ich werde nochmal die Nacharbeiten durchführen und hoffen, dass das diesmal was bringt. Ansonsten bin ich so schlau wie vorher...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

So, nach dem WE kann ich (leider) sagen, dass ein Umzug auf Windows Server 2016 Datacenter keinen Erfolg gebracht hat, der "Fehler: Verbindungsfehler" taucht mit deprimierender Regelmäßigkeit immer wieder auf.

Also habe ich mal im Eventlog gewühlt und weiter gegoogelt. Dabei bin ich über den IIS Dienst gestolpert und hab mal genauer nachgeschaut:

Unter Im IIS Manager unter Anwendungspools  den WSUS Pool geöffnet und den Haken bei "Auslastung des privaten Speichers (in KB)" raus genommen. Dort stand ein Wert von ca 1,5GB drin, was wohl immer dazu geführt hat, dass der IIS Dienst sich nach nicht allzu langer Zeit verabschiedet hat. Warum der Wert so niedrig war, keine Ahnung, aber meine VMs kommen immer recht klein (4GB RAM) aus ihrem Template, vielleicht war das die Ursache...?

Ob das nun wirklich des Pudels Kern war, werde ich weiter beobachten, in der Zwischenzeit betrachte ich das Problem mal als gelöst bis es sich wieder meldet :)

bearbeitet von Maniska

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das klingt doch nach einem guten Einsatz!

Unser WSUS ist 3 Tage nach dem Beitrag Ironischer Weise auch abgetaucht...Wir installieren ihn jetzt auf einem neuen Server und lagern die SQL Datenbank aus, in der Hoffnung der Besserung...

Das mit dem IIS merke ich mir mal für unseren! :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Der Wert scheint ein Standardwert zu sein. Wir hatten in unserer Umgebung auch Probleme mit den Application Pools der WSUSSE, ich habe den Wert flächendeckend auf 4GB angehoben, seitdem haben wir diese Fehler nicht mehr. Es handelt sich dabei um eine gemischte Umgebung ca. 15 WSUS-Server, 2008R2 - 2012R2.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

Melde dich an, um diesem Inhalt zu folgen  

×