Jump to content
Melde dich an, um diesem Inhalt zu folgen  

PHP in der Kommandozeile nutzen 2

Empfohlene Beiträge

Ich habe noch ein anderes Problem und frage jetzt mal in diesem Thread hinterher, damit ich nicht jedes Mal einen neuen aufmache.

Ich will Folgendes über die CMD ausführen, es ist ein Task in meinem Gulpfile.js:

"gulp.task('serve', ['build:local', 'watch'], function() {
  connectphp.server({
    router: './rewrite.php',
    base: './dist/'
  }, function() {
    browsersync({
      proxy: '127.0.0.1:8000'
    });
  });
  gulp.watch('./dist/site/templates/**/*.*').on('change', function() {
    browsersync.reload();
  });
});"

 

Wenn ich diesen Task aufrufe, bekomme ich folgende Fehlermeldungen:

"Warning: readfile(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in Command Line code on line 1

 Warning: readfile(https://getcomposer.org/installer): failed to open stream: No such file or directory in Command line code on line 1

ls: no such file or directory: C:\Users\Home\AppData\Local\Temp/gulp-composer.phar

Failed to download. All options have been exhausted.
[19:20:07] Installation instructions: https://getcomposer.org/doc/00-intro.md
[19:20:07] 'composer' errored after 381 ms
[19:20:07] Error in plugin "gulp-composer"
Message:
    Composer executable does not exist. Self-install was unsuccessful. Please install before continuing."

 

ich habe composer installiert, einmal in meinem node Ordner und einmal über dieses Projekt. das Projekt enthält auch ein composer.json file und ein composer.lock

trotzdem meint er ja composer sei nicht installiert und irgendwas ist bei php nicht richtig konfiguriert.

 

Könnt ihr erkennen, was ich machen muss?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Am 26.10.2018 um 19:35 schrieb PeterNeuer:

"Warning: readfile(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in Command Line code on line 1

 Warning: readfile(https://getcomposer.org/installer): failed to open stream: No such file or directory in Command line code on line 1

Deine Meldung sagt dir bereits, dass PHP nicht daraus konfiguriert ist HTTPS Seiten aufzurufen.

Öffne bitte deine php.ini und suche nach der Zeile 

Zitat

;extension=php_openssl.dll

Entferne dort das Semikolon am Beginn der Zeile und versuche es erneut.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen  

Fachinformatiker.de, 2018 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung