Jump to content

Community durchsuchen

Zeige Ergebnisse für die Stichwörter "'scripting'".

  • Suche mithilfe von Stichwörtern

    Trenne mehrere Stichwörter mit Kommata voneinander
  • Suche Inhalte eines Autors

Inhaltstyp


Forum

  • Forum
  • Ausbildung/Job
    • Ausbildung im IT-Bereich
    • IT-Arbeitswelt
    • IT-Weiterbildung
    • Stellenangebote für Fachinformatiker
    • Jobsuche, Bewerbung und Zeugnisse
  • Prüfungsforen
    • IHK-Prüfung allgemein
    • Prüfungsaufgaben und -lösungen
    • Abschlussprojekte
  • NEU: Frage / Antwort: 1. Frage stellen - 2. Antworten bekommen - 3. Die beste Antwort auswählen
    • Für Systemadministratoren und Netzwerktechniker
    • Für Anwendungsentwickler und Programmierer
  • Fachliche Foren
    • Administration
    • Programmierung
  • Sonstiges
    • News und Feedback zu Fachinformatiker.de
    • Small Talk
  • Gaming Club's Allgemeine Themen
  • Gaming Club's Games
  • Coffeehouse's Themen
  • Coffeehouse's Soap
  • Fachinformatiker.de Treffen's regionale Treffen

Kalender

  • Pruefungen-events
  • Gaming Club's Verabreden zum Zocken
  • Fachinformatiker.de Treffen's Kalender

Product Groups

  • Werben bei Fachinformatiker.de

Blogs

Keine Suchergebnisse

Keine Suchergebnisse


Finde Suchtreffer ...

Suchtreffer enthalten ...


Erstellungsdatum

  • Beginn

    Ende


Zuletzt aktualisiert

  • Beginn

    Ende


Suchtreffer filtern nach ...

Benutzer seit

  • Beginn

    Ende


Gruppe


Website


Ort

3 Ergebnisse gefunden

  1. Servus, brauch mal euren Rat, würde gerne bissel was scripten in Powershell nur fehlt mir ein wenig der Einstieg in das ganze. Habe natürlich Google schon benutzt, aber irgendwie finde ich nicht so gute tutorials. Ist Powershell so komplex, das man sich das nicht selber beibringen kann oder bin ich zu unfähig da was gescheites zu finden ? Danke für eure Antworten Gruß Darkside
  2. Hallo Zusammen, ich wollte einen Drucker via Script installieren lassen, nach bedarf. Weswegen ich ihn nicht per GPOs zuweisen möchte. Mein Script sieht wie folgt aus: set local cscript "C:\Windows\System32\Printing_Admin_Scripts\de-DE\prnport.vbs" -d -r "172.16.0.202" -h "172.16.0.202" -o raw -n 9100" * // Hier soll falls vorhanden der Port erstmal gelöscht werden* cscript "C:\Windows\System32\Printing_Admin_Scripts\de-DE\prnport.vbs" -a -r "172.16.0.202" -h "172.16.0.202" -o raw -n 9100" // Und hier dann wieder erstellt werden mkdir c:\temp\printer copy "\srv-file\MF Software\Treiber und Software\Ricoh MP C401\Neuer Treiber\Ricoh MP C401\disk1" c:\temp\printer //Hier soll der Treiber in einen Lokalen Ordner kopiert werden wie unter "mkdir" angegeben rundll32 printui.dll,PrintUIEntry /ia /f "c:\temp\printer\oemsetup.inf" /r "IP_172.16.0.202" /m "RICOH MP C401 PCL 6" //hier soll der Treiber dann von Lokal installiert werden del c:\temp\printer /Q //Anschließend dann wieder lokal gelöscht werden. pause Ich hoffe es ist halbwegs verständlich und ihr könnt mir bei meinem Problem helfen. Die Datein werden kopiert und wauch wieder gelöscht. nur wird kein Treiber installiert... Was könnte der Grund sein?
  3. Heyho, Ich bau wie schon in dem anderen Thread erwähnt jetzt mein Bash Skript in ein Python skript um. So gesehen kann Python vieles besonders einfacher. Sehr coole Sache auf jeden Fall. Ich habe schon verschiedene XML-Parsing Implementationen ausprobiert, komme aber nich auf einen guten nenner.(lxml, xml.etree.EllementTree, xml.etree.cElementTree, XPATH) Folgende XML-Struktur habe ich. Erstmal ist nur der urn:jboss:domain:datasources:2.0 interessant. <?xml version="1.0" ?> <server xmlns="urn:jboss:domain:2.1"> <extensions> </extensions> <profile> <subsystem xmlns="urn:biz.paluch.logging:logstash-gelf-subsystem:1.0"/> <subsystem xmlns="urn:jboss:domain:logging:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:batch:1.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:datasources:2.0"> <datasources> <datasource jndi-name="java:jboss/datasources/JNDI" pool-name="JNDI" enabled="true"> <connection-url>jdbc:oracle:thin:@//HOST</connection-url> <driver>ojdbc6</driver> <pool> <min-pool-size>50</min-pool-size> <max-pool-size>100</max-pool-size> </pool> <security> <user-name>USER</user-name> <password>PWD</password> </security> <validation> <valid-connection-checker class-name="org.jboss.jca.adapters.jdbc.extensions.oracle.OracleValidConnectionChecker"/> <validate-on-match>false</validate-on-match> <background-validation>true</background-validation> <background-validation-millis>10000</background-validation-millis> <exception-sorter class-name="org.jboss.resource.adapter.jdbc.vendor.OracleExceptionSorter"/> </validation> </datasource> <datasource jndi-name="java:jboss/datasources/JNDI" pool-name="JNDI" enabled="true"> <connection-url>jdbc:oracle:thin:@//HOST</connection-url> <driver>ojdbc6</driver> <pool> <min-pool-size>50</min-pool-size> <max-pool-size>100</max-pool-size> </pool> <security> <user-name>USER</user-name> <password>USER</password> </security> <validation> <valid-connection-checker class-name="org.jboss.jca.adapters.jdbc.extensions.oracle.OracleValidConnectionChecker"/> <validate-on-match>false</validate-on-match> <background-validation>true</background-validation> <background-validation-millis>10000</background-validation-millis> <exception-sorter class-name="org.jboss.resource.adapter.jdbc.vendor.OracleExceptionSorter"/> </validation> </datasource> <datasource jndi-name="java:jboss/datasources/JNDI" pool-name="JNDI" enabled="true"> <connection-url>jdbc:oracle:thin:@//HOST</connection-url> <driver>ojdbc6</driver> <pool> <min-pool-size>50</min-pool-size> <max-pool-size>100</max-pool-size> </pool> <security> <user-name>USER</user-name> <password>USER</password> </security> <validation> <valid-connection-checker class-name="org.jboss.jca.adapters.jdbc.extensions.oracle.OracleValidConnectionChecker"/> <validate-on-match>false</validate-on-match> <background-validation>true</background-validation> <background-validation-millis>10000</background-validation-millis> <exception-sorter class-name="org.jboss.resource.adapter.jdbc.vendor.OracleExceptionSorter"/> </validation> </datasource> <datasource jndi-name="java:jboss/datasources/InstanceConfiguration" pool-name="InstanceConfiguration" enabled="true" use-ccm="true"> <connection-url>jdbc:h2:/path/h2config/InstanceConfiguration;ACCESS_MODE_DATA=r;FILE_LOCK=NO</connection-url> <driver>h2</driver> <security> <user-name>USER</user-name> <password>USER</password> </security> </datasource> <drivers> <driver name="h2" module="com.h2database.h2"> <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class> </driver> <driver name="ojdbc6" module="oracle.ojdbc"> <xa-datasource-class>oracle.ojdbc.xa.client.OracleXADataSource</xa-datasource-class> </driver> </drivers> </datasources> </subsystem> <subsystem xmlns="urn:jboss:domain:deployment-scanner:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:ee:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:ejb3:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:io:1.1"> </subsystem> <subsystem xmlns="urn:jboss:domain:infinispan:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:jacorb:1.3"> </subsystem> <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/> <subsystem xmlns="urn:jboss:domain:jca:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:jdr:1.0"/> <subsystem xmlns="urn:jboss:domain:jmx:1.3"> </subsystem> <subsystem xmlns="urn:jboss:domain:jpa:1.1"> </subsystem> <subsystem xmlns="urn:jboss:domain:jsf:1.0"/> <subsystem xmlns="urn:jboss:domain:jsr77:1.0"/> <subsystem xmlns="urn:jboss:domain:mail:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:messaging:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:naming:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:pojo:1.0"/> <subsystem xmlns="urn:jboss:domain:remoting:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:resource-adapters:2.0"/> <subsystem xmlns="urn:jboss:domain:sar:1.0"/> <subsystem xmlns="urn:jboss:domain:security:1.2"> </subsystem> <subsystem xmlns="urn:jboss:domain:transactions:2.0"> </subsystem> <subsystem xmlns="urn:jboss:domain:undertow:1.1"> </subsystem> <subsystem xmlns="urn:jboss:domain:webservices:1.2"> </subsystem> <subsystem xmlns="urn:jboss:domain:weld:2.0"/> </profile> <interfaces> <interface name="management"> <inet-address value="${jboss.bind.address.management:127.0.0.1}"/> </interface> <interface name="public"> <inet-address value="${jboss.bind.address:127.0.0.1}"/> </interface> <interface name="unsecure"> <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/> </interface> </interfaces> <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}"> <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/> <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9993}"/> <socket-binding name="ajp" port="${jboss.ajp.port:8009}"/> <socket-binding name="http" port="${jboss.http.port:8080}"/> <socket-binding name="https" port="${jboss.https.port:8443}"/> <socket-binding name="jacorb" interface="unsecure" port="3528"/> <socket-binding name="jacorb-ssl" interface="unsecure" port="3529"/> <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/> <socket-binding name="txn-recovery-environment" port="4712"/> <socket-binding name="txn-status-manager" port="4713"/> <outbound-socket-binding name="mail-smtp"> <remote-destination host="localhost" port="25"/> </outbound-socket-binding> <outbound-socket-binding name="remote-ejb"> <remote-destination host="localhost" port="${jboss.http.port:8080}"/> </outbound-socket-binding> </socket-binding-group> </server> Mein Code sähe so aus: In[3]: import xml.etree.cElementTree as xtree In[7]: xml = xtree.parse('standalone-full.xml') In[8]: xml Out[8]: <ElementTree at 0x482e588> In[9]: root = xml.getroot() In[10]: root Out[10]: <Element '{urn:jboss:domain:2.1}server' at 0x0000000004836030> In[11]: root.getchildren() Out[11]: [<Element '{urn:jboss:domain:2.1}extensions' at 0x0000000004836060>, <Element '{urn:jboss:domain:2.1}system-properties' at 0x0000000004836AE0>, <Element '{urn:jboss:domain:2.1}management' at 0x0000000004836B70>, <Element '{urn:jboss:domain:2.1}profile' at 0x000000000483CB40>, <Element '{urn:jboss:domain:2.1}interfaces' at 0x000000000490F8A0>, <Element '{urn:jboss:domain:2.1}socket-binding-group' at 0x000000000490FC30>] In[13]: for children in root.findall('{urn:jboss:domain:2.1}profile'): ... datasources = children.find('{urn:jboss:domain:datasources:2.0}datasources') ... print datasources ... NoneJemand ne Idee wie ich das anstellen kann? Danke.

Fachinformatiker.de, 2019 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung