Jump to content

Batch: RUNAS starten von dsa.msc unter Win8.1 nichtmehr möglich

Empfohlene Beiträge

Hallo,

unter Windows7 hatte ich mir Batches für meine wichtigstens Admin Tools geschrieben, um nicht dauernd rechtsklick -> ausühren als -> Administrator, Kennwort eingeben zu müssen.

Jetzt mit Win8.1 startet zwar das CMD Fenster, und die Batch läuft auch ganz durch

post-86876-14430449983084_thumb.png

post-86876-14430449982806_thumb.png

Natürlich besitze ich lokale Adminrechte. Und der Benutzer der im Script eingetragen ist, ist Domänen-Admin.

Für die, die das Interessant und Sinnvoll finden hier der Quellcode

@echo off

rem ********************************************

rem ***    RUNAS-Script für AD-Verwaltung    ***

rem ********************************************


rem 1.) einfach bei den Variablen user und domain die jeweiligen Informationen eingeben.

rem 2.) beim ersten ausführen dieser Batch wird nach dem zugehörigen Passwort gefragt

rem 3.) der Parameter /savecred speichert dann das eingegebene Passwort.

rem	keine Ahnung wie und wo, ist aber ein Standardparamter des runas-Befehls.

REM Das heißt: Das Kennwort muss bei erstmaliger Nutzung 1x angegeben werden, und wird dann gecached! 


set user=xx

set domain=xx


set tool=%windir%\system32\dsa.msc


if exist %tool% goto START

cls

echo Das Programm wurde nicht gefunden.

echo Bitte die RSAT Tools installieren!

echo.

echo.

pause



:START

runas /savecred /user:%domain%\%user% "mmc %tool%"

cls

echo.

echo %tool% successfully started as User %domain%\%user%.

timeout 5

[/code]

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
warum setzt du nicht einfach den haken dafür auf der verknüpfung unter properties?

Weil mein User für den Tagesgebrauch aus Sicherheitsgründen nur lokaler Admin ist.

Und weil der Haken nichts helfen würde.

Probier mal:

runas /profile /env /savecred /user:%domain%\%user% "mmc %tool%"

Ja, gemacht ...

post-86876-14430449987962_thumb.png

bearbeitet von tschulian

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gut, wie es aussieht hast du nie mit runas Scripten und dem Parameter /savecred gearbeitet.

In dem Script steht nur die Domain und der Benutzername. Das Passwort für den Benutzer muss 1x beim ersten Scriptstart eingeben werden. Danach wird das Passwort (wahrscheinlich verschlüsselt) gespeichert. Kann es nicht bestätigen und nichts im Internet finden, aber ich denke hier

Systemsteuerung\Benutzerkonten\Anmeldeinformationsverwaltung

Außerdem geht es hier nicht um Sicherheit sondern rein darum in Erfahrung zu bringen, weshalb der runas Befehl unter Win8 nichtmehr funktioniert.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nimm an der Diskussion teil

Du kannst jetzt hier posten und Dich später registrieren. Wenn Du bereits über eine Konto verfügst, melde Dich jetzt an, um mit Deinem Konto zu posten.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.


Fachinformatiker.de, 2019 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung