Zum Inhalt springen
Melde dich an, um diesem Inhalt zu folgen  

Webseite sehr langsam

Empfohlene Beiträge

Guten Tag,

von der Feuerwehr haben wir folgende Domain: http://www.ortsfeuerwehr-lohne.de/

Leider läd Sie beim ersten mal immer um die 11 Sekunden...

Die Seite wird bei Strato gehostet.

Jemand eine Ahnung woran das liegen könnte? Oder meint ihr die Bilder etc. sind noch zu groß?

Vielen Dank!

Bearbeitet von murat1895

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich würde vielleicht mal Strato fragen. Es dauert 12 Sekunden, bis man das erste Byte der Webseite bekommt.
Ich kann nicht sagen, wo das Problem liegt. Das müsste man jetzt auf dem Server analyiseren. Das kann sehr viel sein. z.B. Probleme mit der Datenbankverbindung. Eigenartig ist, dass es nur beim initialen Aufbau der Webseite ist.

Beim Initialen Aufbau der Webseite sehen so die Zeiten aus:

01.png

Beim zweiten Aufrufen:02.png

Wenn man ein Root-Zugriff und auch schon keine Analysetools hat, dann sollte Strato dies mal anschauen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe die Seite mal geschwind untersucht. Was direkt auffällt ist, dass dieses Bild direkt auf der Startseite, welches ganze 8 Sekunden benötigt hat. Auch viele andere Bilder benötigen ca. eine viertel Sekunde. Das Problem hierbei ist, dass ein Browser pro Seite maximal 30 Verbindungen pro URL oder IP (weiß gerade nicht genau) verwendet (per default). Darum werden 30 Ressourcen/Requests gleichzeitig geladen und erst wenn hier wieder welche fertig sind, werden die nächsten nachgeladen. Auf der Startseite habe ich 50 Requests gezählt. (Youtube, Facebook usw. umgehen das, indem sie andere Domains für Inhalte verwenden, nur so als Info am Rande).

Also habe ich mir auch andere Bilder auf der Seite angeschaut, sehr oft sind sie viel größer gespeichert, als sie auf der Webseite verwendet werden. Zum Beispiel hier wird das Blaulicht mit ca. 629x260 angezeigt, aber ist als 1305x540 Pixel gespeichert. Außerdem spart PNG auch einiges gegenüber JPEG.

Die Seite an sich (index.php) läd in ~1,5 Sekunden, was zwar verkraftbar wäre aber dennoch in der heutigen Zeit nicht schnell ist. Woran das liegt, kann man nicht genau sagen, ich habe habe schließlich keinen Zugriff auf den Server. Ich kann also nur vermuten.

  • Habt ihr denn einen VServer? Wie viele Ressourcen sind denn tatsächlich zur Verwendung
  • Wie wird PHP eingebunden, per FastCGI oder als Modul?
  • Habt ihr Datenbankabfragen, die schlanker gemacht werden können? Ggf. auf dem Datenbankserver überprüfen, wo und ob Optimierungsbedarf besteht
  • Stehen in den Logs (Apache bzw. nginx, PHP, ...) irgendwelche Seltsamen Dinge?
  • Laufen auf dem Server andere Prozesse, die eine hohe Traffic erzeugen oder extrem viele Ressourcen (CPU, RAM) benötigen? 
  • Habt ihr ungewöhnlich viele Zugriffe von außen (Angriffe)?
  • Brauchen irgendwelche PHP-Skripte ungewöhnlich viel Arbeitsspeicher?

Mehr fällt mir momentan nicht ein. Gewonnen hast du schon einmal ein wenig, wenn du dich um die Bilder kümmerst. Alles andere muss untersucht werden. 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 8 Stunden schrieb pr0gg3r:

Ich habe die Seite mal geschwind untersucht. Was direkt auffällt ist, dass dieses Bild direkt auf der Startseite, welches ganze 8 Sekunden benötigt hat.

Bei meiner 50 MBit/s-Leitung dauert es 2 Sekunden und dennoch braucht die Webseite beim initialen Aufbau für das erste Byte 12 Sekunden. Da sind die Bilder erst mal irrelevant.

vor 8 Stunden schrieb pr0gg3r:

Habt ihr Datenbankabfragen, die schlanker gemacht werden können? Ggf. auf dem Datenbankserver überprüfen, wo und ob Optimierungsbedarf besteht

Es wird Joomla verwendet. Von daher denke ich schon, dass die Abfragen schon optimiert worden sind.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Eine Möglichkeit:

Initial benötigt die Abarbeitung der Cookies einen Moment, bis die Website an den Request angepasst aufgearbeitet wurde. Beim Wiederholungszugriff steht dann ein Usercookie bereit und Inhalte sind bereits lokal verfügbar (Bilder, Zusatzscripte, Navigationsverhalten).

Grüße

Micha

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Deine Meinung

Du kannst jetzt schreiben und Dich später registrieren. Wenn Du ein Konto hast, melde Dich an , um mit Deinem Konto zu schreiben.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Nur 75 Emojis sind erlaubt.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

Melde dich an, um diesem Inhalt zu folgen  

Fachinformatiker.de, 2020 SE Internet Services

fidelogo_small.png

if_icon-6-mail-envelope-closed_314900.pnSchicken Sie uns eine Nachricht!

Fachinformatiker.de ist die größte IT-Community
rund um Ausbildung, Job, Weiterbildung für IT-Fachkräfte.

Fachinformatiker.de App


Get it on Google Play

Kontakt

Hier werben?
Oder senden Sie eine E-Mail an

Social media u. feeds

Jobboard für Fachinformatiker und IT-Fachkräfte

×
×
  • Neu erstellen...

Wichtige Information

Fachinformatiker.de verwendet Cookies. Mehr dazu in unserer Datenschutzerklärung