Jump to content
Melde dich an, um diesem Inhalt zu folgen  

Windows: Verbindung von zwei Netzwerken

Empfohlene Beiträge

Hallo zusammen,

ich habe gerade ein Problem beim Verbinden eines Netzwerkes mit dem Internet über ein anderes Netzwerk.

Habe mir schon einige Seiten durchgelesen, aber bisher hat es mir nicht geholfen.

 

Mein Netzwerk:

Netzwerk 1: mit Internetzugriff

9.9.9.0/24

- Server1: Windows SBS 2011 (AD/DNS/DHCP)

Netzwerkkarte: 9.9.9.100 / 24, DNS 9.9.9.100, GW 9.9.9.254

Netzwerk 2: ohne Internetzugriff (an Netzwerk 1 angehängt)

2.2.2.0/26

- Server2: Windows Server 2012 R2 (AD/DNS/DHCP)

Netzwerkkarte1: 2.2.2.1 / 26, DNS 2.2.2.1

Netzwerkkarte2: 9.9.9.120 / 24, DNS 9.9.9.100, GW 9.9.9.254

Route Server1:

route add 2.2.2.0 MASK 255.255.255.192  -  9.9.9.120

Route Server2:

route add 9.9.9.0 MASK 255.255.255.0  -  9.9.9.120

route add 2.2.2.0 MASK 255.255.255.192  -  2.2.2.1

 

Ich kann von Server2 beide Netzwerke komplett und auch das Internet erreichen.

Andere Clients / Server im Netzwerk2 erreichen nur das eigene Netzwerk (auch, wenn ich auf dem Client die Route 9.9.9.0 /24 2.2.2.1 hinterlege). Internetzugriff aus Netzwerk2 entsprechend auch nicht möglich, aber DNS Auflösung funktioniert!

Aus Netzwerk1 erreiche ich das Netzwerk2 nicht, aber natürlich die 9.9.9.120

 

Im Endeffekt brauche ich, dass ich aus dem Netzwerk2 das Internet erreiche. Habe jetzt verschieden mit Routen / DNS / GW & Firewall Einstellungen getestet, aber ich bekomme die Verbindung nicht hin.

Hat jemand einen Tipp oder eine Anleitung für mich?

 

 

bearbeitet von fenack

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstmal: hast Du wirklich diese Subnetze oder hast Du die wegen Verschleierung geändert? Im zweiteren Fall bringt dir das null komma gar nichts, solange Du private IP-Ranges nutzt, die im Internet sowieso nicht geroutet werden und Du kannst auch die echten Subnetze angeben.

Dann:

vor 23 Minuten schrieb fenack:

Netzwerk 2: ohne Internetzugriff (an Netzwerk 1 angehängt)

Was heißt "angehängt"? Kannst Du das bitte mal aufzeichnen? So wie Du das beschreibst steige ich da nämlich nicht durch, wie das physikalisch miteinander verbunden ist, und ohne dass man weiß, wie das physikalisch miteinander zusammen hängt, ist das nur ein Ratespiel.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Zunächst Entschuldigung für die späte Antwort.
Gestern hatte ich neben der UNI keine Zeit hierfür....

Am 8.1.2018 um 17:59 schrieb Eye-Q:

Erstmal: hast Du wirklich diese Subnetze oder hast Du die wegen Verschleierung geändert? Im zweiteren Fall bringt dir das null komma gar nichts, solange Du private IP-Ranges nutzt, die im Internet sowieso nicht geroutet werden und Du kannst auch die echten Subnetze angeben.

Die Subnetze stimmen. Aber ich habe die IP Adresse geändert, damit es eindeutiger ist.
Bei 192.168.16.0/24 und 192.168.17.0/26 kann sonst schnell mal was vertauscht werden.

 

Am 8.1.2018 um 17:59 schrieb Eye-Q:

Was heißt "angehängt"? Kannst Du das bitte mal aufzeichnen? So wie Du das beschreibst steige ich da nämlich nicht durch, wie das physikalisch miteinander verbunden ist, und ohne dass man weiß, wie das physikalisch miteinander zusammen hängt, ist das nur ein Ratespiel.

Am 9.1.2018 um 09:27 schrieb BlackIP:

Hilfreich wäre ein Netzplan. So ist es wirklich sehr unübersichtlich.

Hier der Netzplan:

5a55eed251ae2_2018-01-1011_44_18-neu0-yEd.png.0a07015f60a36d4d56fb9c5fda8a18bf.png

Auf dem Server2 läuft die Test-Domain und HyperV.
HyperV nutzt die zweite Netzwerkkarte für das Netzwerk 2.
 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Soll das bei Netzwerk 1 ein Router oder ein Switch sein?

Wenn man vom Router ausgeht, dann muss auf dem Server 2 eine Default Route auf die IP-Adresse des Routers (das wo die Kugel dran verbunden ist) eingestellt werden

route add 0.0.0.0 MASK 0.0.0.0  [IP des Routers]

Zusätzlich muss das Routing zwischen den beiden Netzen (9.9.9.0/24 und 2.2.2.0/24) aktiviert werden. Da directly connected werden eigentlich keine zusätzlichen Routen benötigt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das ist der Router bei Netzwerk 1.

 

auf dem Server2 habe ich folgende ständige Routen:

Netzwerkadresse Netzmaske Gatewayadresse Metrik
0.0.0.0 0.0.0.0 9.9.9.254 Standard
9.9.9.0 255.255.255.0 9.9.9.120 1
2.2.2.0 255.255.255.192 2.2.2.1 1
bearbeitet von fenack

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ok, ich hatte noch einen Fehler im Routing zwischen den Netzen.

 

Ich habe auf der zweiten Netzwerkkarte das Forwarding aktiviert, aber nicht auf der ersten...

jetzt habe ich den Zugriff zwischen beiden Netzwerken. Danke für die Tipps. So bin ich auf die Ursache gestoßen.

 

Mich hatte nur verwundert, dass DNS aufgelöst wurde. Daher dachte ich, dass das Routing zwischen den Netzen korrekt war...

Wieder was gelernt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

Melde dich an, um diesem Inhalt zu folgen  

×